Merhaba Arkadaşlar,

Konu başlığında olduğu gibi Aruba Access Point cihazlarını fabrika ayarlarına alma ve yeniden konfigürasyonunu yapabileceğiniz komutları aşağıda paylaşıyorum.

Aruba ailesinde bulunan tüm Access Point cihazlarını aşağıdaki komutlar yardımı ile sıfırlayabilir yada yeniden konfigürasyonunu yapabilirsiniz. Bu komutları işleyebilmek için aşağıdaki adımları yapmanız gerekiyor.

 

Öncelikle bir PC üzerinde SecureCRT yada Putty gibi bir yardımcı uygulama ile console ayarlarınızı yapmanız gerekiyor. Baud rate tanımınız 9600 olması gerekiyor. Cihazın arkasında bulunan Console girişine console kablonuzu bağladıktan sonra, cihazın “Enet” bağlantısını yaptıktan sonra cihaz açılırken console üzerinde boot ekranına düşene kadar “Enter” tuşuna basmanız gerekiyor. Boot ekranına düştükten sonra aşağıdaki komutları sırasıyla giriyoruz.

 

purgeenv
factory_reset
clear os 0
clear os 1
setenv serverip x.x.x.x (Controller IP adresi)
setenv master x.x.x.x   (Controller IP adresi)
setenv remote_ap 1   (AP cihazı RAP durumda çalışacak ise bu komutu yazıyoruz. Eğer Campus mode çalışacak ise bu komutu yazmıyoruz.)
save
boot

 

Yukarıdaki komutları yazıp cihazı reboot ettikten sonra, cihaz DHCP üzerinden bir IP alarak, Controller cihazına erişiyor. TFTP ile arka planda config dosyasını kendisine yüklüyor. Bu işlemler sonrasında cihaz açıldıktan sonra Controller tarafında gerekli tanımların yapılarak cihazın ilgili profil altına alınması yeterli olacaktır.

 

Kolay Gelsin.

Merhaba Arkadaşlar,

Bir Cisco Router cihazının şifresini unuttuğunuz zaman yada mevcut şifresini kırmak istiyorsanız, bu işlemi gerçekleştirmek çok kolay. Sadece Router cihazının yanında olmanız gerekiyor. Yanınızda PC + Console var ise aşağıdaki adımları izlemeniz yeterli olacaktır.

 

Öncelikle PC üzerinde SecureCRT yada Putty gibi bir console uygulaması gerekiyor. MAC vs. kullanıyorsanız terminal üzerinden de kolay bir şekilde console bağlantısı yapabilirsiniz.

Kullandığınız program üzerinde baud rate ayarınız 9600 olması gerekiyor.

Router’ın arkasındaki console girişine console kablonuzu bağladıktan sonra, PC üzerinden cihazın console yönetimini yapabildiğinize emin olduktan sonra, cihazı reboot ederek sırasıyla aşağıdaki adımları yapmanız gerekiyor.

 

Cihaz reboot edildikten hemen sonra açılırken klavye üzerinde

“CTRL + BREAK” tuşlarına basmanız gerekiyor. Taki “rommon >” ekranına düşene kadar. Rommon moduna düştükten sonra aşağıdaki komutları sırasıyla yazmanız gerekiyor.

(Bu mode üzerinde normalde olduğu gibi tab ile komut tamamlama çalışmaz. Tüm komutları elle yazmanız gerekiyor 🙂

 

Aşağıda yazdığımız komut ile birlikte cihazı başka bir cihazmış gibi içi boş bir şekilde açmış olacağız. Böylece cihazın şifresini değiştirebileceğiz.(-_-)

rommon > confreg 0x2142

rommon > reset

 

Yukardaki komutları yazdıktan sonra cihaz sıfır bir cihazmış gibi tekrar açılacaktır. Asıl işlemleri şimdi yapmaya başlayacağız. Aşağıdaki komutlar ile devam ediyoruz.

 

Router>
Router> enable
Router# copy startup-config running-config
Destination filename [running-config]? (hit enter)
Building configuration…
[OK]
Router# configure terminal
Router(config)# enable secret cisco

Router(config)# line vty 0 4

Router(config)# password cisco

Router(config)# login

 

Bildiğiniz üzere yaptığımız config sayesinde cihaz sıfır bir cihazmış gibi açıldı. Üst bölümde yazmış olduğum config sayesinde cihazın nvram bölümünde tutulan mevcut config bilgilerini cihaza tekrar yüklemiş oldum. Bu sayede hem cihazın eski konfigürasyonunu kaybetmemiş olduk. Ek olarak yeni bir enable ve telnet şifresi tanımlamış olduk.

 

Hatırlarsanız “rommon” üzerinde cihazın register kaydını değiştirmiştik. Bu sayede cihaz sıfır bir konfigürasyon ile açılmıştır. Şifremizi değiştirdiğimize göre artık bunu register kaydını olması gerek duruma getirerek cihazımız üzerinde yaptığımız konfigürasyonu kaydedebiliriz.

 

Router(config)# config-register 0x2102
Router(config)# exit
Router# copy running-config startup-config
Destination filename [startup-config]? (hit enter)
Building configuration…
[OK]
Router# reload   “Register kaydının etkin olabilmesi için cihazın reboot edilmesi zorunludur.”

 

Yukarıdaki işlemleride yaptıktan sonra cihaz reboot sonrasında Router cihazımız mevcut konfigürasyon ve vermiş olduğumuz yeni şifre ile açılacaktır.

 

Tüm bunları yaparken lütfen dikkat edin. Mevcut konfigürasyonu kaybetmeyin 🙂

Kolay Gelsin.

 

 

Merhaba Arkadaşlar,

Airwave default root password’u aşağıdaki gibidir.

 

Login = root

Password = admin

 

Kolay Gelsin.

 

 

Merhaba Arkadaşlar,

Genel olarak ilk adım da MacBook kullanıcıları PC’leri üzerinde nasıl Screenshot alacağını bilemiyor. Bu sebeple zorluk çekebiliyorlar. Mevcut durumda 2 tuş kombinasyonu ile çok rahat bir şekilde screenshot alabiliyoruz.

 

Aşağıdaki tuş kombinasyonunu kullanabilirsiniz.

Yöntem – 1

Command-Shift-3 bu kombinasyon ile tüm ekranın screenshot’ını alırsınız.

 

Yöntem – 2

Command-Shift-4 bu kombinasyon ile istemiş olduğunuz bölümü crop yardımı ile screenshot alabilirsiniz.

 

Kolay Gelsin.

 

 

Merhaba Arkadaşlar,

Excel Workbook üzerinde aynı anda birden fazla kullanıcının çalışma yapabilmesi için excel üzerinde yapılması gereken adımların resimlerini derledim. Aş
ağıdaki adımları izleyerek birden fazla kişi aynı anda excel üzerinde işlem yapabilir.

Kolay Gelsin.

Adım – 1

excel,share

 

Adım – 2

excel 2

 

 

 

Merhaba Arkadaşlar,

Aruba’nın ürünü olan ClearPass’ın genel olarak default password’u ile ilgili problem yaşayabilirsiniz. Default password bilgisini aşağıda paylaşıyorum.

 

Username : appadmin
Password: eTIPS123 

 

Merhaba Arkadaşlar,

Linux makinelerde mevcut diskin boyunutu genişlettikten sonra eklenilen yeni disk alanının kullanılabilmesi için bildiğiniz gibi bu ham halin mount edilmesi gerekir. Aşağıdaki script yardımı ile birlikte bu işlemi çok kolay bir şekilde gerçekleştirebilirsiniz. Her zaman öncesinde sunucunun yedeğinii almanızda fayda var.

 

Not : VM diskler LVM olarak kurulmuş olmalı.

Script

Disk alanı genişletildikten sonra sunucu CLI üzerinde aşağıdaki komutları yazıyoruz.

distro=$(cat /etc/issue | head -n 2 | tr -d “\n” | tr “[:upper:]” “[:lower:]”)

device=$(fdisk -l | grep -w 8e | head -n 1 | cut -c-8)

partcount=$(fdisk -l | grep $device | sed 1d | grep -c $device)

newpartnum=$(($partcount+1))

startsector=$(fdisk -l | grep -w 8e | tail -1 | tr ” ” “\n” | sed “/^$/d” | head -n 3 | tail -1)

newstartsector=$(($startsector+1))

endsector=$(fdisk -l | grep sectors | head -n 1 | tr ” ” “\n” | tail -2 | head -n 1)

newendsector=$(($endsector-1))

fdisk $device <<EOF

n

p

$newpartnum

$newstartsector

$newendsector

t

$newpartnum

8e

w

EOF

partprobe

komutları girdikten sonra sunucuyu reboot ediyoruz.

reboot

 

<Sunucuyu reboot ettikten sonra ikinci adım olarak aşağıdaki komutları giriyoruz.>

 

device=$(fdisk -l | grep -w 8e | head -n 1 | cut -c-8)

partnumber=$(fdisk -l | grep $device | sed 1d | grep -c $device)

pvcreate $device$partnumber

volgroupname=$(vgdisplay | grep -w “VG Name” | cut -b10- | tr -d ” “)

vgextend $volgroupname $device$partnumber

volgroupchars=$(echo $volgroupname | wc –chars)

totalchars=$(($volgroupchars+13))

lvmname=$(df -h | grep -w $volgroupname | head -n 1 | cut -b$totalchars-)

set $lvmname

lvmname=$1

lvextend -l +100%FREE /dev/$volgroupname/$lvmname

resize2fs /dev/$volgroupname/$lvmname

Kontrolü için;

df -h

Merhaba Arkadaşlar,

Özellikle okul topolojilerinde DHCP server fiziksel bir makine üzerinde VM’de çalışmaktadır. Eğer lokal networkünüzde vlan yapılandırılması varsa, switch’ler üzerinde DHCP Relay’e ihtiyaç duyabilirsiniz. Juniper EX Serisi switch’ler üzerinde bu konfigürasyon örneği aşağıdaki gibidir.

Farklı vlan ve network’ler için aşağıdaki örneği kullanabilirsiniz.

 

set forwarding-options helpers bootp server 172.16.44.4  (DHCP Server)
set forwarding-options helpers bootp interface vlan.10
set forwarding-options helpers bootp interface vlan.20
set forwarding-options helpers bootp interface vlan.30
set forwarding-options helpers bootp interface vlan.40
set forwarding-options helpers bootp interface vlan.50
Relay çalışması için interface’lere IP vermek gerekiyor.
set interfaces vlan unit 10 family inet address 172.16.44.250/24
set interfaces vlan unit 20 family inet address 172.16.45.250/24
set interfaces vlan unit 30 family inet address 172.16.46.250/24
set interfaces vlan unit 40 family inet address 172.16.47.250/24
set interfaces vlan unit 50 family inet address 10.12.254.250/16

Merhaba Arkadaşlar,

G.shdsl kiralık hatlar son zamanlarda VDSL port üzerinden verililiyor. Bu sebeple mevcut G.shdsl config’ler malesef çalışmıyor. Bu durumun önüne geçebilmek için aşağıdaki konfigürasyon örneğini kullanabilirsiniz. Her model VDSL port’u desteklememektedir. Cisco  C887VA-K9 modeli üzerinde bu hattı sonlandırabilirsiniz.

Kolay Gelsin.

Building configuration…

Current configuration : 1913 bytes
!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco_VDSLP2P
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
enable secret xxxxxxxx
!
no aaa new-model
memory-size iomem 10
!
!
!
no ip domain lookup
ip domain name rems.de
ip cef
no ipv6 cef
!

!
multilink bundle-name authenticated
!
!
license udi pid C887VA-K9 sn FCZ193260E9
!
!
controller VDSL 0
!
!
!
bridge irb
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
pvc 0/35
  encapsulation aal5snap
!
!
interface Ethernet0
no ip address
!
interface Ethernet0.15
encapsulation dot1Q 15
ip address x.x.x.x x.x.x.x.x/30
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
no ip address
!
interface Dialer1
mtu 1492
ip address negotiated
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp ipcp dns request
!
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
!

access-list 66 remark *** telnet access ***
access-list 66 permit x.x.x.x x.x.x.x
!
control-plane
!
bridge 1 protocol ieee
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 66 in
password 7 xxxxxx
login
transport input all
!
scheduler allocate 20000 1000
!
end

Merhaba Arkadaşlar,

Cisco 800 serisi bir cihaz üzerinde ADSL hat sonlandıracaksınız, aşağıda paylaşmış olduğum konfigürasyon örneğini kullanabilirsiniz.

Ben bu konfigürasyon ile Cisco 800 serisi üzerinde ADSL hattı sağlıklı bir şekilde çalıştırabilirsiniz.

NOT : Konfigürasyon örneğinde DHCP ve NAT örneğide mevcuttur.

ADSL hattın çalışması için gerekli olan esaslı komutlar bold olarak işaretlenmiştir.

DHCP ve NAT komutları

ADSL hat komutları olarak renklendirişmiştir.

Bu konfigürasyon yardımcı ile ADSL hattınızı sağlıklı bir şekilde çalıştırabilirsiniz. Ek olarak config içinde bulunan DHCP ve NAT tanımları sayesinde router’ın ethernet portları arkasından direkt olarak IP alıp, internet erişimi mevcut haldedir.

Kolay Gelsin.

 

Building configuration…

Current configuration : 1596 bytes
!
! No configuration change since last restart
!
version 12.4
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname Cisco_800
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
enable secret xxxxxxx
!
no aaa new-model
clock timezone gmt+2 2
clock summer-time gmt+3 recurring
!
!
dot11 syslog
ip source-route
!
ip dhcp pool Cisco_dhcp
   network 192.168.12.0 255.255.255.0
   dns-server 212.58.3.2 212.58.4.2
   default-router 192.168.12.1
!
!
ip cef
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.12.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
ppp pap sent-username cisco@cisco.com password xxxxxxx        “ADSL kullanıcı adı ve şifresi bu bölümde giriliyor.”
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 remark *** nat ***
access-list 1 permit 192.168.12.0 0.0.0.255
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password xxxxx
login
!
scheduler max-task-time 5000
ntp server 65.55.56.206
end